Python 2.7? Does python 3 work?

Avatar

By lukejodonnell 30 Jul 2016 17:02

Member · 10 comments

I'm trying to install the source code, but I already have python installed.  I have python 3.3.3, and I'll probably update because I think that's slightly out of date.  Is 2.7 required?  I know there were a lot of changes in version 3, will the code still work?

Avatar

By xirsoi 30 Jul 2016 19:31

Champion · 66 comments

Honestly, it's a little weird that Tuxemon is using 2.7. Support was dropped for it over 5 years ago, most major libraries have been Python3.x compatible for years.


Avatar

By benneti 30 Jul 2016 20:32

Member · 38 comments

Afaik the development Branche does work in Python 3 but the master branch did not (I tried it myself just a few days ago)

Avatar

By bitcraft 2 Aug 2016 17:21

Champion · 166 comments

Yes, generally its better to use the development branch.  Some platforms don't have python3 (android, maybe?) so I don't see us dropping 2.7 support, at least on the game client.